PAT (Advanced Level) 1013. Battle Over Cities (25) 并查集

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
并查集,新技能+1。
也可以用DFS或BFS做,判断失去一个城市后还有多少连通子图。
/*2015.7.20cyq*/
#include <iostream>
#include <vector>
using namespace std;
//并查集
int findroot(vector<int> &root,int a){
	if(root[a]!=a)
		root[a]=findroot(root,root[a]);//路径压缩,本结点更新为根结点的子结点
	return root[a];
}

int graphNum(const vector<pair<int,int> > &roads,int N,int lostCityNum){
	vector<int> root;
	for(int i=0;i<=N;i++)
		root.push_back(i);//一开始每个结点的根结点都是自身
	int result=N-1;//失去一个城市后,最多有N-1个子图
	for(auto it=roads.begin();it!=roads.end();it++){
		if((*it).first!=lostCityNum&&(*it).second!=lostCityNum){
			int ar=findroot(root,(*it).first);
			int br=findroot(root,(*it).second);
			if(ar!=br){
				result--;
				root[ar]=br;
			}
		}
	}
	return result;
}
int main(){
	int N,M,K;
	cin>>N>>M>>K;

	vector<pair<int,int> > roads;
	int a,b;
	while(M--){
		cin>>a>>b;
		roads.push_back(make_pair(a,b));
	}
	int x;
	while(K--){
		cin>>x;
		cout<<graphNum(roads,N,x)-1<<endl;//子图数减1
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值