HDU 1005 Number Sequence(找规律)

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 171269    Accepted Submission(s): 42263


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1008 1021 1019 1009 1012 



一看递推公式和取模,再一看数据范围,不会错的,找规律找周期啊

一开始先想写个记忆化搜索来输出找规律,后来实在找不着周期的规律ORZ

然后才想到,取值只可能是0,1,2,3,4,5,6,然后组合就有才49个,只要循环找循环节就可以了

找循环节的方法:找相邻两项分别和相邻周期的相邻数字相同的即可(表达都能把自己绕晕了) 因为公式里每项只与它前面两项有关。

好,算的方法我也错了。。。开始没注意到前面有可能不是完整的循环节,直接用n%(end-st)结果wa了。。。

还有很多要注意的啊。。。QAQ


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <map>
#include <vector>
#include <set>
#define maxn 10000
#define inf 0x3f3f3f3f3f3f
#define mod 1000007
typedef long long ll;


using namespace std;
int dp[maxn];
int a,b,n;
ll solve(int a,int b,int n)
{
    if(dp[n]!=-1)return dp[n];
    else return dp[n]=((a%7*solve(a,b,n-1)%7)%7+(b%7*solve(a,b,n-2)%7)%7)%7;
}
int main()
{
    while(scanf("%d%d%d",&a,&b,&n)==3)
    {
        if(a+b+n==0)break;
        memset(dp,0,sizeof(dp));
        dp[1]=dp[2]=1;
        int st=1,end=1;
        bool flag=false;
        for(int i=3;i<=n&&!flag;i++)
        {
            dp[i]=((a%7*dp[i-1])%7+(b%7*dp[i-2])%7)%7;
            for(int j=2;j<i;j++)
            {
                if(dp[i]==dp[j]&&dp[i-1]==dp[j-1])
                {
                    st=j;
                    end=i;
                    flag=true;
                    break;
                }
                //如果找到了相邻两位是一样的就等于找到了一个循环节
                //因为每项只与它前两项有关(即相邻两项)
            }
        }
        if(st==end)
        {
            printf("%d\n",dp[n]);
        }


        else printf("%d\n",dp[st+(n-end)%(end-st)]);
        //写成了n%(end-st)怎么也过不了,后来才知道是st前有可能是不完整循环节
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值