HDU 1005 Number Sequence(找规律,思维)

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 153140    Accepted Submission(s): 37338


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1019  1071  1006  1007  1013 
 



题意:

给定 a,b,n 求出 f(n) 的值,题设条件 f(1),f(2)已知。


思路:

看到 n 值那么大,用递归没可能了,找规律: f(n)的取值一共有七种,无论 a,b 的取值是多少,均不下于  0,1,2,3,4,5,6  ,存在循环周期的节点,

找循环的节点就行了。

循环开到100就超时了,最后看的题解,开到了50。(49也行)


代码:

#include<stdio.h>
#define MYDD 1103

int main() {
	int a,b,n;
	int f[64];
	while(scanf("%d%d%d",&a,&b,&n)&&(a||b||n)) {
		int flag,j;//flag 记录结束标志
		f[1]=f[2]=1;
		for(j=3; j<=7*7+1; j++) {
			f[j]=(a*f[j-1]+b*f[j-2])%7;
			if(f[j]==1&&f[j-1]==1) {
				break;
			}
		}
		flag=j-2;//记录循环的开始节点
		f[0]=f[flag];//余数为 0 时
		printf("%d\n",f[n%flag]);
	}
	return 0;
}

后:

思维是什么?

************************************


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值