HDU 1005 Number Sequence 水题 规律题

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 161058    Accepted Submission(s): 39591


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1008  1004  1021  1019  1003 
 
水题,其实一点都不水,直接模拟的话一定会超时,题目中直接要求的每一个结果都对7取模,说明f(i)一定是0-7之间的数,也就是说明f[n]=a*f[n-1]+b*f[n-2]一定有49种可能,也就是说最多不会超过49个为一个循环,再多再多,也就50个呗;
ac代码
#include <stdio.h>
#include <math.h>
#include <stdlib.h>

int data[55]={1,1,1};//其实55就可以的 ,循环嘴都也就50个 

int main()
{
	int a,b,n;
	int beg,end;
	int i,j,flag;
	
	while(scanf("%d%d%d",&a,&b,&n),a||b||n)
	{
		flag=0;
		for(i=3;i<=n&&!flag;i++)
		{
			data[i]=(a*data[i-1]+b*data[i-2])%7;
			for(j=2;j<i-1;j++)
			{
				if(data[i]==data[j]&&data[i-1]==data[j-1])
				{
					beg=j;
					end=i;
					flag=1;//标记下来开始循环位,结束循环位 
					break;
				}
			}
		}
		if(flag)
		{
			printf("%d\n",data[beg+(n-end)%(end-beg)]);
		}
		else
		{//如果没达到循环,就直接输出 
			printf("%d\n",data[n]);
		}
	}
	
	return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值