fzu1669(毕达哥拉斯不定方程)

这是一道关于数论的问题,要求找出所有满足直角三角形性质a+b+c≤40的直角三角形个数。题目提供了5个具体的例子,并提示参考数论教材p116页。
摘要由CSDN通过智能技术生成
Problem 1669 Right-angled Triangle

Accept: 50    Submit: 100
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

A triangle is one of the basic shapes of geometry: a polygon with three corners or vertices and three sides or edges which are line segments. A triangle with vertices A, B, and C is denoted △ABC.
Triangles can also be classified according to their internal angles, described below using degrees of arc:
  • A right triangle (or right-angled triangle, formerly called a rectangled triangle) has one 90° internal angle (a right angle). The side opposite to the right angle is the hypotenuse; it is the longest side in the right triangle. The other two sides are the legs or catheti (singular: cathetus) of the triangle. Right triangles conform to the Pythagorean Theorem, wherein the sum of the squares of the two legs is equal to the square of the hypotenuse, i.e., a^2 + b^2 = c^2, where a and b are the legs and c is the hypotenuse.
  • An oblique triangle has no internal angle equal to 90°.
  • An obtuse triangle is an oblique triangle with one internal angle larger than 90° (an obtuse angle).
  • An acute triangle is an oblique triangle with internal angles all smaller than 90° (three acute angles). An equilateral triangle is an acute triangle, but not all acute triangles are equilateral triangles.
What we consider here is very simple. Give you the length of L, you should calculate there are how many right-angled triangles such that a + b + c ≤ L where a and b are the legs and c is the hypotenuse. You should note that the three numbers a, b and c are all integers.

Input

There are multiply test cases. For each test case, the first line is an integer L(12≤L≤2000000), indicating the length of L.

Output

For each test case, output the number of right-angled triangles such that a + b + c ≤ L where a and b are the legs and c is the hypotenuse.

Sample Input

1240

Sample Output

15

Hint

There are five right-angled triangles where a + b + c ≤ 40. That are one right-angled triangle where a = 3, b = 4 and c = 5; one right-angled triangle where a = 6, b = 8 and c = 10; one right-angled triangle where a = 5, b = 12 and c = 13; one right-angled triangle where a = 9, b = 12 and c = 15; one right-angled triangle where a = 8, b = 15 and c = 17.

数论教材p116;

求满足以a,b为直角边,c为斜边,且满足a+b+c<=L的直角三角形的个数

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int gcd(int a,int b)
{
    if(b==0)    return a;
    else    return gcd(b,a%b);
}
void solve(int L)
{
    int x,y,z,m,n,i,ans,temp;
    ans=0;
    temp=sqrt(L+0.0);
    for(n=1;n<=temp;n++)
    {
        for(m=n+1;m<=temp;m++)
        {
            if(m*m+n*n>L)
                break;
            if(m%2!=n%2)
            {
                if(gcd(m,n)==1)
                {
                    x=m*m-n*n;
                    y=2*m*n;
                    z=m*m+n*n;
                    for(i=1;;i++)
                    {
                        if(i*(x+y+z)>L)
                            break;
                        ans++;
                    }
                }
            }
        }
    }
    printf("%d\n",ans);
}
int main()
{
    int L;
    while(scanf("%d",&L)!=EOF)
    {
        solve(L);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值