pku 1308 Is It A Tree?(并查集)

Is It A Tree?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17954 Accepted: 6148

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source


题意:每组数据以一对0 0结束,整个程序以一对-1 -1结束,每一对数字x y代表y是x的子结点,即有一条有向边由x指向y,问题是,给出的数据是否构成一颗树。
题解:首先要知道如何才能构成一棵树,以下有几种情况不符合的:
1.根结点有多个,则有多棵树。
2.一棵树的某个结点可以由根结点通过2条或以上的路径到达。
该题可以用并查集的方法解决,开一个数组v【i】代表v【i】的值的其中一个后代是i
判断是否一棵树的矛盾点是,对每一个录入的x和y查找它的最终的根a和b,若不相等,则合并x和y的根结点v【a】=b,若相等,由于x指向y,则表明有2条路径可以到达a(b),则不是一棵树
所有操作合并完仍没有矛盾点的话,就判断根结点个数,对每一个i寻找最终根,判断是否只有唯一最终根,若不是,则也不是一棵树
其中并查集查找最终的根的核心代码如下:
int f(int x)
{
    if(x==v[x]) return x;
    else return v[x]=f(v[x]); //可以逐步刷新父结点
}
ps:一旦知道不是一棵树,就可以停止操作

#include <stdio.h>
#include <string.h>
int v[1000005],mark[1000005];
int f(int x)
{
    if(x==v[x]) return x;
    else return v[x]=f(v[x]);
}
int main()
{
    int t=1,n,m,x,y,i,flag,maxn,num;

    while(maxn=-1,flag=1,1)
    {
        scanf("%d%d",&n,&m);
        if(n<0&&m<0) break;
        for(i=1;i<=1000000;i++) v[i]=i;
        memset(mark,0,sizeof(mark));
        while(n!=0&&m!=0)
        {
            mark[n]=mark[m]=1;
            if(n>maxn) maxn=n;
            if(m>maxn) maxn=m;
            if(flag)
            {
                x=f(n);   y=f(m);
                if(x==y) flag=0;
                else v[x]=y;
            }
            scanf("%d%d",&n,&m);
        }
        if(flag)
        {
            num=0;
            for(i=1;i<=maxn;i++)
            {
                if(mark[i]==0) continue;
                x=f(i);
                if(mark[x]==1){ mark[x]++;   num++; }
                if(num>1){ flag=0; break; }
            }
        }
        printf("Case %d is ",t++);
        if(flag) printf("a tree.\n");
        else printf("not a tree.\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值