hdu 3006 The Number of set(位运算)

                                                      The Number of set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 956    Accepted Submission(s): 594


Problem Description
Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
 

Input
There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.
 

Output
For each case,the output contain only one integer,the number of the different sets you get.
 

Sample Input
  
  
4 4 1 1 1 2 1 3 1 4 2 4 3 1 2 3 4 1 2 3 4
 

Sample Output
  
  
15 2
 

Source
 

Recommend
gaojie

题意:k个数算一个集合,n个集合,集合中的数最大不大于m(m小于等于14)
题解:位运算....挺好用的啊啊啊啊啊啊啊啊啊啊啊啊,用一个位代表一个是否已取,1代表已取,0则反之,共用14个位的数就可以代表一个集合~~~

#include<stdio.h>
#include<string.h>
int cc[1<<15];
int main()
{
    int temp,c,MAX,cou,i,n,m,k;

    while(scanf("%d%d",&n,&m)>0)
    {
        memset(cc,0,sizeof(cc));
        while(n--)
        {
            temp=0;
            scanf("%d",&k);
            while(k--)
            {
                scanf("%d",&c);
                temp=temp|(1<<(c-1));
            }
            cc[temp]=1;
            for(MAX=1<<m,i=0;i<=MAX;i++)
            {
                if(cc[i]) cc[temp|i]=1;
            }
        }
        for(cou=i=0;i<=MAX;i++)
            if(cc[i]) cou++;
        printf("%d\n",cou);
    }

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值