Play the Dice hdu 4586 数学期望的问题

Play the Dice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 710    Accepted Submission(s): 253
Special Judge


Problem Description
There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.
 

Input
Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.
 

Output
Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.
 

Sample Input
  
  
6 1 2 3 4 5 6 0 4 0 0 0 0 1 3
 

Sample Output
  
  
3.50 0.00
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:   4822  4821  4820  4819  4818


这个题目其实想想还是蛮不容易,不过我给力的队友依旧还是做出了这个题目。假如说第一次所得期望是a的话,那么第二次所得到的期望就是a+a*(m/n),接着这样推下去,根据等比公式即可得到答案,而a=sum/n,
因为我们在第一次的时候期望就是sum/a,p=∑(n) a0 * q^(i-1), q = (m/n) , a0=sum/n

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N=220;

int a[N],b;
int n,m;

int main(){



    while(~scanf("%d",&n)){
        int sum=0;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        //printf("sum=%d\n",sum);
        scanf("%d",&m);
        for(int i=0;i<m;i++)
            scanf("%d",&b);
        if(sum==0){
            printf("0.00\n");
            continue;
        }
        if(n==m){
            printf("inf\n");
            continue;
        }
        printf("%.2lf\n",1.0*sum/(n-m));
    }
    return 0;
}




 
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值