1028. 人口普查(20)

1028. 人口普查(20)
某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。
输入样例:

5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:

3 Tom John

#include<iostream>
#include<fstream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
typedef struct{

    string name;
    int year;
    int month;
    int day;

}people;
int str2int(string s)
{
    int sum=0;
    int mut=1;
    for(int i=s.size()-1;i>=0;i--)
    {
        sum+=(s[i]-'0')*mut;
        mut=mut*10;
    }
    return sum;
}
bool compare(people a,people b)
{
    if(a.year==b.year)
    {
        if(a.month==b.month)
        {
            if(a.day==b.day)
                return false;
            else
                return a.day<b.day;

        }
        else
            return a.month<b.month;
    }
    else
        return a.year<b.year;

}
int main()
{
    fstream file("data.txt");
    string line;
    getline(file,line);
    int num=*line.c_str()-'0';
    vector<people> peoples;
    people p1={"max",1814,9,6};
    people p2={"min",2014,9,6};
    for(int i=0;i<num;i++)
    {
        string tmp;
        people p;
        getline(file,tmp);
        int pos=tmp.find_first_of(' ',0);
        p.name=tmp.substr(0,pos);
        int pos1=tmp.find_first_of('//',pos+1);
        p.year=str2int(tmp.substr(pos+1,pos1-pos-1));
        int pos2=tmp.find_first_of('//',pos1+1);
        p.month=str2int(tmp.substr(pos1+1,pos2-pos1-1));
        p.day=str2int(tmp.substr(pos2+1,tmp.size()-pos2));
        if(compare(p,p1))
            continue;
        if(compare(p2,p))
            continue;
        peoples.push_back(p);
    }
    sort(peoples.begin(),peoples.end(),compare);
    cout<<peoples.size()<<" "<<peoples[0].name<<" "<<peoples[peoples.size()-1].name<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值