poj 2431 Expedition (贪心+优先队列)

28 篇文章 0 订阅
4 篇文章 0 订阅
Expedition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6890 Accepted: 2065

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source

比较简单的一个题目,只不过题目意思比较难以理解,我读了好几遍题目才把意思弄明白,题目意思是一辆卡车距离城镇有L距离,车中还有P油量,每向前行驶一单位距离消耗一单位的油量,如果在途中卡车中就没有油了 ,就无法到达终点;途中有N个加油站,加油站提供的油量有限,卡车的油箱是无限的,给出每个加油站距离终点的距离和提供的油量,问卡车在途中最少需要加几次油。
这个题目就要用到贪心的思想,先去提供油量比较多的地方,距离又比较近的地方,用优先队列来储存每一次的油量;只要油量恰好能够到达终点,所加的次数就是最小的;
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn=10001;
typedef struct node
{
    int dis,fuel;
}node;
node stop[maxn];
bool cmp(node x,node y)//比较大小,题目中给的是到终点的距离
{
   return x.dis>y.dis;
}
int main()
{
    int n,l,p;
    int ans=0,j=0,temp;
    while(scanf("%d",&n)!=EOF)
    {
    priority_queue<int>q;
    for(int i=0;i<n;i++)
        scanf("%d %d",&stop[i].dis,&stop[i].fuel);
    scanf("%d %d",&l,&p);
    sort(stop,stop+n,cmp);
    q.push(p);//起始的油量入队
    while(l>0 && !q.empty())
    {
        ans++;
        temp=q.top();
        q.pop();
        l-=temp;//油量能够支撑的距离
        while(j<n && l<=stop[j].dis)//到终点的距离进行比较
            q.push(stop[j++].fuel);//加油站提供的油量
    }
    printf("%d\n",l<=0?ans-1:-1);
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值