Mondriaan's Dream - POJ 2411 状压dp

Mondriaan's Dream
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 11231 Accepted: 6534

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

题意:就是用1*2的方格组成1个row*col的矩形,问你有多少种组合方式。

思路:状压dp。dp[i][S]表示当i-1行满的时候,第i行以S状态可以有多少种,0表示空,1表示竖着的,11表示横着的。如果i-1行的S状态的某一列是0,那么i这一行,对应的那列必为1。如果i-1行的S状态的某一列是1,那么i这一行,对应的那列可以为0。同时,如果上一行有两个连续的1,这一行也可以有两个连续的1。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
long long dp[15][2500],ans[15][15];
int row,col;
void init(int S,int len)
{ if(len==col)
  { dp[0][S]++;
    return;
  }
  if(len<col)
   init(S<<1,len+1);
  if(len+1<col)
   init((S<<2)+3,len+2);
}
void dfs(int a,int S1,int S2,int len)
{ if(len==col)
  { dp[a][S1]+=dp[a-1][S2];
    return;
  }
  if(len<col)
  { dfs(a,S1<<1,(S2<<1)+1,len+1);
    dfs(a,(S1<<1)+1,S2<<1,len+1);
  }
  if(len+1<col)
   dfs(a,(S1<<2)+3,(S2<<2)+3,len+2);
}
int main()
{ int i,j,k,temp;
  while(~scanf("%d%d",&row,&col) && row)
  { if(ans[row][col]>0)
    { printf("%I64d\n",ans[row][col]);
      continue;
    }
    if((row*col)&1)
    { printf("0\n");
      continue;
    }
    memset(dp,0,sizeof(dp));
    init(0,0);
    for(i=1;i<row;i++)
     dfs(i,0,0,0);
    ans[row][col]=ans[col][row]=dp[row-1][(1<<col)-1];
    printf("%I64d\n",ans[row][col]);
  }
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值