Mondriaan's Dream

这道题堪称经典的状压dp的题目了。


题目:

quares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!
Input
The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.
Output
For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.
Sample Input
1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0
Sample Output
1
0
1
2
3
5
144
51205
题目就像图中的意思一样。就是有多少种方案。

题目分析:每一个位置都与上一个位置有关,而且也有可能影响其他的状态。

其实仔细分析就是三种:

 //如果这个位置被上一列占用,直接跳过
    if(((1<<j)&sta)>0)
    dfs(i,j+1,sta,next);
    //如果这个位置是空的,尝试放一个1*2的
    if(((1<<j)&sta)==0)
    {
        dfs(i,j+1,sta,next|(1<<j));
    }
    //如果这个位置和下个位置都是空的,尝试放一个2*1的
    if(j+1<N&&((1<<j)&sta)==0&&((1<<j+1)&sta)==0)
    {
        dfs(i,j+2,sta,next);
    }
这道题我是按列来做的。实际上按行也可以。
dp[i][j]用来表示第i列的状态为j。用j二进制表示各个位置放与不放

注意数组的大小。刚开始开成了dp[12][1<<12]反正就是小了

状态的储存和转移


#include<iostream>
#include<string.h>
using namespace std;
int N,M;
int i,j;
//long long dp[12][34];
long long dp[13][1<<12];
void dfs(int i,int j,int sta,int next)//第i列。第j行。sta当前列的状态,next对下一列的影响
{
    if(j==N)//j到了最后一行
    {
        dp[i+1][next]+=dp[i][sta];
        return ;
    }
    //如果这个位置被上一列占用,直接跳过
    if(((1<<j)&sta)>0)
    dfs(i,j+1,sta,next);
    //如果这个位置是空的,尝试放一个1*2的
    if(((1<<j)&sta)==0)
    {
        dfs(i,j+1,sta,next|(1<<j));
    }
    //如果这个位置和下个位置都是空的,尝试放一个2*1的
    if(j+1<N&&((1<<j)&sta)==0&&((1<<j+1)&sta)==0)
    {
        dfs(i,j+2,sta,next);
    }
    return;

}
int main()
{
    while(cin>>N>>M)
    {
        memset(dp,0,sizeof(dp));
        if(N==0&&M==0)
            break;
        dp[1][0]=1;//第一列开始不铺
        for(int i=1;i<=M;i++)
        {
            for(j=0;j<(1<<N);j++)
            {
                if(dp[i][j])
                {
                    dfs(i,0,j,0);
                }
            }
        }
        cout<<dp[M+1][0]<<endl;
    }
}









评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值