Wall Painting

Wall Painting
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2557 Accepted Submission(s): 814

Problem Description
Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B.
When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with different plans.

For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6.
Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him?
You should tell Mr.Fang the answer from the first day to the n-th day.

Input
There are several test cases, please process till EOF.
For each test case, the first line contains a single integer N(1 <= N <= 103).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.

Output
For each test case, output N integers in a line representing the answers(mod 106 +3) from the first day to the n-th day.

Sample Input
4
1 2 10 1

Sample Output
14 36 30 8

Source
2013ACM/ICPC亚洲区南京站现场赛——题目重现

wa了无数遍 ~~ 只是因为取余没有掌握好QAQ
题意是让求好多n个数里面挑1-n个数的异或和
计算每一位做的贡献就好了
改了无数遍凑活看O_O 没有打注释

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <stack>

using namespace std;
typedef long long LL;
const int mod=1000003;
int n;
LL num[1150];
LL ans[1150];
LL f[1150][1150];
bool cmp(int a,int b)
{
    return a>b;
}
void init()
{
    memset(f,0,sizeof(f));
    for(int i=0;i<1150;i++)
        f[i][0]=f[i][i]=1;
    for(int i=1;i<1150;i++)
        for(int j=1;j<i;j++)
            f[i][j] = (f[i-1][j]+f[i-1][j-1])%mod;
}
int main(){
    init();
    while(~scanf("%d",&n)){
        memset(ans,0,sizeof(ans));
        memset(num,0,sizeof(num));
        for(int i=1;i<=n;i++)
            scanf("%lld",&num[i]);
        sort(num+1,num+n+1,cmp);
        LL ml=1;
        while(num[1]){
            LL cnt1=0;
            for(int i=1;i<=n;i++){
                if(!num[i])
                    break;
                if(num[i]&1)
                    cnt1++;
                num[i]>>=1;
            }
            for(int i=1;i<=n;i++){
                LL cnt=0;
                for(int j=1;j<=i;j+=2){
                      cnt+=f[cnt1][j]*f[n-cnt1][i-j]%mod;
                }
                cnt=cnt*ml%mod;
                ans[i]=(ans[i]+cnt)%mod;
            }
            ml=ml*2%mod;
        }
        for(int i=1;i<n;i++)
            printf("%lld ",ans[i]);
        printf("%lld\n",ans[n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值