HDU4565 So Easy!(数学+矩阵快速幂)

So Easy!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Problem Description
  A sequence S n is defined as:

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
  You, a top coder, say: So easy! 
 

Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2 15, (a-1) 2< b < a 2, 0 < b, n < 2 31.The input will finish with the end of file.
 

Output
  For each the case, output an integer S n.
 

Sample Input
  
  
2 3 1 2013 2 3 2 2013 2 2 1 2013
 

Sample Output
  
  
4 14 4
 

这题有个神奇的条件:(a-1)^2< b < a^2 => a-1 < sqrt(b) < a
这就是说(a + sqrt(b))^n的共轭式(a - sqrt(b))^n < 1
设Cn = An + Bn = (a + sqrt(b))^n + (a - sqrt(b))^n = [An] = [(a + sqrt(b))^n]
也就是说Sn = Cn
Cn是可以递推的:Cn两边同乘(a + sqrt(b)) + (a - sqrt(b)) : 
Cn[ (a + sqrt(b)) + (a - sqrt(b)) ] = [(a + sqrt(b))^n + (a - sqrt(b))^n] * [ (a + sqrt(b)) + (a - sqrt(b)) ] 
= Cn+1 + (a^2 - b)Cn-1

Cn+1 = 2aCn + (b - a^2)Cn-1 ←喜闻乐见的矩阵了。。。
20140924194624.png

#include <iostream>
#include <cstdio>
#include <cstring>
#define LL long long
using namespace std;
LL a,b,n,mod;
struct Mvt
{
    LL v[3][3];
    Mvt operator * (Mvt &rhs)
    {
        Mvt ret;
        for(int i=0;i<2;i++)
        {
            for(int j=0;j<2;j++)
            {
                ret.v[i][j]=0;
                for(int k=0;k<2;k++)
                {
                    ret.v[i][j]+=v[i][k]*rhs.v[k][j]%mod;
                }
                ret.v[i][j]%=mod;
            }
        }
        return ret;
    }
};
Mvt mul(Mvt x,LL p)
{
    Mvt ans;
    ans.v[0][0]=ans.v[1][1]=1;
    ans.v[1][0]=ans.v[0][1]=0;
    while(p>0)
    {
        if(p&1)
            ans=ans*x;
        x=x*x;
        p>>=1;
    }
    return ans;
}

int main()
{
    while(scanf("%lld%lld%lld%lld",&a,&b,&n,&mod)!=EOF)
    {
        if(n==1)
        {
            printf("%lld\n",a*2%mod);
            continue;
        }
        Mvt tmp;
        tmp.v[0][0]=2*a%mod;
        tmp.v[0][1]=(b-a*a)%mod;
        tmp.v[1][0] = 1;
        tmp.v[1][1] = 0;
        tmp=mul(tmp,n);
        LL ans = ((2 * a * tmp.v[1][0] + 2 * tmp.v[1][1])%mod+mod)%mod;
        printf("%lld\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值