POJ 1837 Balance 类似01背包

题目描述:

Description

Gigel has a strange “balance” and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm’s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.
Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-’ for the left arm and ‘+’ for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights’ values.
Output

The output contains the number M representing the number of possibilities to poise the balance.
Sample Input

2 4 
-2 3 
3 4 5 8

Sample Output

2

题目描述:

一个天平,有C个挂钩(固定),G个砝码,其中挂钩值与其挂钩上的砝码重量之和的乘积为其对天平的力矩。挂钩值小于零说明在天平左边,大于零说明在天平右边,现要求天平平衡,求砝码放置的方法总数。
类似01背包的dp题,不同是本题的砝码必须全都用上,所以需要对其状态进行记录,dp[i][j]的意义就是在前i个砝码被放置的时候j状态的值。但是这个状态我们该如何表示呢?就是用平衡系数表示,其小于0表示向左偏,大于0表示向右偏,等于0表示平衡。但是数组下标不能为负数,所以我们需要将这个状态向右移动一个适当大的数。这个数究竟是多少其实不是特别重要,只要满足在所有数据范围中的答案都是正确就可以了。我们知道将所有砝码都放在最左边的挂钩上的值就是该天平最向左倾的情况,也是这个适当大的数的大小,是-15(挂钩最小值)*20(最多砝码数)*25(最大砝码重量)=7500。
所以dp[i][7500]表示的是平衡状态。

代码如下:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>

using namespace std;

const int MAXN=21;
int dp[MAXN][15010];//dp[i][j]表示前i个砝码在j平衡状态下的值

int C[MAXN],G[MAXN];
int NumC,NumG;
int main()
{
    while(scanf("%d%d",&NumC,&NumG)!=-1)
    {
        for(int i=1; i<=NumC; i++)
        {
            scanf("%d",&C[i]);
        }
        for(int i=1; i<=NumG; i++)
        {
            scanf("%d",&G[i]);
        }
        memset(dp,0,sizeof(dp));
        dp[0][7500]=1;
        for(int i=1; i<=NumG; i++)
        {
            for(int j=0; j<=15000; j++)
            {
                for(int k=1; k<=NumC; k++)
                {
                    if (j>=C[k]*G[i])//j状态允许在k位置放置i砝码
                       dp[i][j]+=dp[i-1][j-C[k]*G[i]];
                       //状态转移方程
                }
            }
        }
        printf("%d\n",dp[NumG][7500]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值