hdu4324(拓扑排序)

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2138    Accepted Submission(s): 898


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

Author
BJTU


题解:

      本题要求给定的有向图里是否又a->b->c->a的三角形环。由于矩阵中任意两点有么有正向边,要么有反向边,所以只要有环,就能构成三角形环。证明如下:假设有n元环,a->b->c……->a,若c->a有边,则存在三角形环a->b->c->a;若无边,则说明不存在c->a的边从而存在a->c的边,于是有n元环a->b->c……->a变成有n-1元环,a->c……->a,最终可以证明存在三角形环。时间复杂度为拓扑排序的O(n*n),在本题可以接受。

#include<iostream>
#include<cstring>
using namespace std;

const int MAXN=2000+10;
int inDev[MAXN];
bool visited[MAXN];
bool g[MAXN][MAXN];
char str[MAXN];
int n;

void init()
{
	memset(g,0,sizeof(g));
	memset(visited,0,sizeof(visited));
	memset(inDev,0,sizeof(inDev));
}

void input()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%s",str);
		for(int j=0;j<n;j++)
		{
			if('1'==str[j])
			{
			g[i][j]=true;
			++inDev[j];
			}
		}
	}
}

void topSort()  
{  
    int i,tag=0,k=0;  
    while(k<n)  
    {  
		for(i=0;i<n;i++)
			if(!visited[i]&&0==inDev[i])
				break;
		if(i>=n)
		{
			tag=1;
			break;
		}
		++k;
		visited[i]=true;
		for(int j=0;j<n;j++)
			if(g[i][j]&&inDev[j]!=0)
				--inDev[j];
    }  
	if(tag)
		printf("Yes\n");
	else printf("No\n");
}  

int main()
{
	int cas,tag=0;
	cin>>cas;
	while(cas--)
	{
		init();
		input();
		printf("Case #%d: ",++tag);
		topSort();
	}
	system("pause");
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值