PAT A1046 Shortest Distance (20)

题目地址:https://www.patest.cn/contests/pat-a-practise/1046

题目描述:

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入格式(Input Specification):

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

输出格式(Output Specification):

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

输入样例(Sample Input):

5 1 2 4 14 9
3
1 3
2 5
4 1

输出样例(Sample Output):

3
10
7


题意:

有N个结点围城一个圈,相邻两个点之间的距离已知,且每次只能移动到相邻点。然后给出M个询问,每个询问给出两个数字A和B即结点编号(1<=A,B<=N),求从A号结点到B号结点的最短距离。

样例解释:

如图所示,共有5个结点,分别标号为1、2、3、4,相邻两点的距离在图上给出。总共三个询问:
13:从1号点到3号点的最短距离为3,路径为1->2->3;
25:从2号点到5号点的最短距离为10,路径为2->1->5;
41:从4号点到1号点的最短距离为7,路径为4->3->2->1。


解题思路:

步骤 1:以dis[ i ]表示 1 号结点按顺时针方向到达”i 号结点顺时针方向的下一个结点“的距离(1 <= i <= N),sum 表示一圈的总距离。于是对每个查询 left ->right,其结果就是 dis( left , right ) 与 sum - dis(left , right)中的较小值。
步骤 2:dis 数组和 sum 在读入时就可以进行累加得到。这样对每个查询 left -> right,dis(left,right)其实就是 dis[ right - 1] - dis[left - 1]。这样可以做到查询复杂度为O(1)。

注意:

  • 查询的两个点的编号可能会有 left > right 的情况。这样情况下,需要交换 left 和 right
  • 此题若没有经过预处理 dis 数组和 sum 的做法会很容易超时
  • 之所以不把 dis[ i ] 设置为 1 号结点按顺时针方向到达 i 号结点的距离,是因为 N 号结点到达 1 号结点的距离无法被这个数组所保存

C++完整代码如下:

#include<cstdio>
#include<algorithm>
using namespace std;

const int MAXN = 100005;
int dis[MAXN], A[MAXN];    // dis数组含义已说明,A[I] 存放 i 号与 i+1 号顶点的距离
int main(){
  int sum = 0, query, n, left, right;
  scanf("%d", &n);
  for(int i = 1; i <= n; i++){
    scanf("%d", &A[i]);
    sum += A[i];    //累加 sum
    dis[i] = sum;     //预处理 dis 数组 
  }
  scanf("%d", &query);
  for(int i = 0; i < query; i++){      //query 个查询
    scanf("%d%d", &left, &right);    // left -> right
    if(left > right) swap(left, right);  //left -> right 时交换 
    int temp = dis[right - 1] - dis[left - 1];
    printf("%d\n", min(temp, sum - temp));
  } 
  return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L). To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river. Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N). FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks. Input Line 1: Three space-separated integers: L, N, and M Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position. Output Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks Sample Inputcopy Outputcopy 25 5 2 2 14 11 21 17 4 Hint Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
最新发布
07-24

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值