1046. Shortest Distance (20)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortestdistance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

提交代

——————————

简单题目

主要是下标有点儿混乱

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int N,M;

int main(int argc, char** argv) {
	int i=0;
	
	scanf("%d",&N);
	vector<int> distance(N+1);
	vector<int> sum(N+1,0);
	int total=0;
	for(i=1; i<=N; i++){
		scanf("%d",&distance[i]);
		total+=distance[i];
		sum[i+1]=sum[i]+distance[i];
	}
	scanf("%d",&M);
	while(M--){
		int d1,d2;
		scanf("%d %d",&d1,&d2);
		int tmp=abs(sum[d2]-sum[d1]);
		int res=min(tmp,total-tmp);
		printf("%d\n",res);
	}

	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值