PAT_A1046 Shortest Distance

PAT学习笔记之A1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1 D2 ⋯ DN , where DI is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104) , with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

思路:

  1. 刚开始想构造int类型dis[]数组存放输入的D1 D2 ⋯ DN,再顺时针累加得r与逆时针累加得l,比较得两点间最小距离。但这样的时间复杂度过大,第三个case超时。
  2. 调整思路,在输入各距离时顺便累加,得总距离sum,在后面的代码中只顺时针累加两点间的距离得r,逆时针的距离l由sum-r得到,减少计算量。提交测试,第三个case仍然超时,好吧,看来第三个case的点不少。
  3. 再调整思路,此时将dis[]数组改为存放各点到1的距离,即每次累加得的sum赋值给dis[],输入的*D1 D2 ⋯ DN*由d过渡,这样在需要求得两点间距离时 r=dis[b-1]-dis[a-1],l=sum-r,时间复杂度大大降低,答案正确。

tip:注意 a b 的次序问题,a=min(a,b),b=max(a,b),如果不对需互换。

完整代码:

#include <iostream>
using namespace std;

int main() {
    int n,m,d,dis[100000];
    int i,a,b,l,r,sum=0;
    if(scanf("%d",&n)){};
    for(i=1;i<=n;i++){
        if(scanf("%d",&d)){
            sum+=d;
            dis[i]=sum;
        }
    }
    if(scanf("%d",&m)){};
    while (m--) {
        if(scanf("%d%d",&a,&b)){};
        l=0;
        r=0;
        if(a>b){
            swap(a, b);
        }
        r=dis[b-1]-dis[a-1];
        l=sum-r;
        printf("%d\n",r<=l?r:l);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值