PAT-A1046 Shortest Distance 题目内容及题解

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​^4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

题目大意

题目给定高速公路上的N个出口,它们构成一个简单的循环,说出任意两个出口之间的最短距离。

解题思路

  1. 读入数据时计算其和,得到环线的总长度;
  2. 计算每组数据时始终保持从小数到大数,计算其中距离;
  3. 输出两种到达方式中较小的答案并返回0值。

代码

#include<stdio.h>
#define maxn 100010
int main(){
    int N,M;
    int a,b,c,sum;
    int i;
    int dis[maxn]={0};
    int end[maxn]={0,0};
    scanf("%d",&N);
    for(i=1;i<=N;i++){
        scanf("%d",&dis[i]);//i-i+1
        end[i]=end[i-1]+dis[i-1];
    }
    sum=end[N]+dis[N];
    scanf("%d",&M);
    for(i=0;i<M;i++){
        scanf("%d%d",&a,&b);
        if(a>b){
            c=b;
            b=a;
            a=c;
        }
        c=end[b]-end[a];
        printf("%d\n",(sum-c)<c?(sum-c):c);
    }
    return 0;
} 

运行结果

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值