PAT--1127. ZigZagging on a Tree

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
这里写图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

题解

先由中序、后序序列构建出二叉树,再求出层序遍历的序列,每一层的序列是一个数组,输出的时候,第0层之外的偶数层逆转就ok啦。

#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <queue>
using namespace std;

const int maxn = 50 + 5;
int n;
int in[maxn], post[maxn];

struct TreeNode{
    int key;
    TreeNode* left;
    TreeNode* right;
    TreeNode(int k):key(k), left(NULL), right(NULL){}
};

TreeNode* build(int* in, int* post, int n){
    if(n == 0) return NULL;
    TreeNode* node = new TreeNode(post[n - 1]);
    int pos = 0;
    for(; pos < n && in[pos] != post[n - 1]; ++pos) ;
    int left = pos, right = n - pos - 1;
    node->left = build(in, post, left);
    node->right = build(in + left + 1, post + left, right);

    return node;
}

void zigzagging(TreeNode* root){
    queue<TreeNode*> Q;
    vector<vector<int>> ans;
    vector<int> tmp;
    Q.push(root);
    Q.push(NULL);
    while(!Q.empty()){
        TreeNode* p = Q.front(); Q.pop();
        if(p == NULL){
            ans.push_back(tmp);
            tmp.clear();
            if(Q.size() > 0) Q.push(NULL);
        }else{
            tmp.push_back(p->key);
            if(p->left)  Q.push(p->left);
            if(p->right) Q.push(p->right);
        }
    }

    for(int i = 0; i < ans.size(); ++i){
        if(i && i % 2 == 0) reverse(ans[i].begin(), ans[i].end());
    }

    for(int i = 0; i < ans.size(); ++i){
        for(int j = 0; j < ans[i].size(); ++j){
            if(i || j) cout << " ";
            cout << ans[i][j];
        }
    }

}

int main(){
#ifndef ONLINE_JUDGE
freopen("data.in", "r", stdin);
#endif // ONLINE_JUDGE

    cin >> n;
    for(int i = 0; i < n; ++i) cin >> in[i];
    for(int i = 0; i < n; ++i) cin >> post[i];

    TreeNode* root = build(in, post, n);
    zigzagging(root);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值