1127 ZigZagging on a Tree

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15
啊啊啊啊啊啊,一个po题,我写了将近3小时,不是多难,首先模板打错了一个地方,花了很长时间,接着一个小错误也找了半天,现在身心俱疲。。写代码很快,找bug找半天,我丢,再也不想经历了,本想下午多做点题目的。。不多说了= =

#include<iostream>
#include<vector>
#include<queue> 
using namespace std;
struct node{
	int value;
	node *lchild,*rchild;
};
int post[35],in[35],n,num[35],cnt;
node* create(int postl,int postr,int inl,int inr){
	if(postl > postr){
		return NULL;
	} 
	node* root = new node;
	root->value = post[postr];
	int k;
	for(k=inl;k<=inr;k++){
		if(in[k] == post[postr]) break;
	}
	int num=k-inl;
	root->lchild=create(postl,postl+num-1,inl,k-1);
	root->rchild=create(postl+num,postr-1,k+1,inr);
	return root;
}
void bfs(node* root){
	vector<node*> v;
	v.push_back(root);
	int flag=1;
	while(v.size()){
		int len=v.size();
		for(int i=0;i<len;i++){
			if(v[i]->lchild !=NULL) v.push_back(v[i]->lchild);
			if(v[i]->rchild !=NULL) v.push_back(v[i]->rchild);
		}
		
		if(flag){
            for(int i = len - 1; i >= 0; i--){
                num[cnt++] = v[i]->value;
            }
            flag=0;
        }else{
			for(int i=0;i<len;i++){
				num[cnt++] = v[i]->value;
		    }
		    flag=1;
		}
		v.erase(v.begin(),v.begin()+len);
	}
}
int main(){
	cin>>n;
	for(int i=0;i<n;i++) cin>>in[i];
	for(int i=0;i<n;i++) cin>>post[i];
	node* root = create(0,n-1,0,n-1);
	queue<node*> q;
	q.push(root);
	bfs(root);
	for(int i=0;i<n;i++){
		if(i<n-1) cout<<num[i]<<' ';
		else cout<<num[i];
	}
	return 0;
} 

参考

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值