1127 ZigZagging on a Tree (30分)【重建二叉树/Z字型遍历二叉树】

2 篇文章 0 订阅
1 篇文章 0 订阅

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

 

题解:

 

思路:链表重建二叉树→BFS求层次遍历顺序,按层保存→设置标记位flag正逆遍历每层输出Z字型

#include <iostream>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;

struct node
{
	int data, depth;
	node* l;
	node* r;
};
int n, post[31], in[31], maxndeep = 0;
vector<node*> eachlevel[31];

node* createtree(int inl, int inr, int postl, int postr, int depth) {
	if (postr < postl) return NULL;
	node* root = new node;
	root->data = post[postr];
	root->depth = depth;
	int k = inl;
	while (in[k] != post[postr] && k <= inr) k++;
	int leftnum = k - inl;
	root->l = createtree(inl, k - 1, postl, postl + leftnum - 1, depth + 1);
	root->r = createtree(k + 1, inr, postl + leftnum, postr - 1, depth + 1);
	return root;
}

void BFS(node* root) {
	queue<node*> q;
	q.push(root);
	while (!q.empty())
	{
		node* now = q.front();
		maxndeep = max(maxndeep, now->depth);
		eachlevel[now->depth].push_back(now);
		q.pop();
		if (now->l != NULL) q.push(now->l);
		if (now->r != NULL) q.push(now->r);
	}

}

int main() {
	cin >> n;
	vector<int> res(n);
	for (int i = 0; i < n; i++)
		cin >> in[i];
	for (int i = 0; i < n; i++)
		cin >> post[i];
	node* root = createtree(0, n - 1, 0, n - 1, 0);
	BFS(root);

	cout << root->data;
	int flag = 0;
	for (int i = 1; i <= maxndeep; i++)
	{
		if (flag == 0) 
		{
			for (int j = 0; j < eachlevel[i].size(); j++)
			{
				cout << ' ' << eachlevel[i][j]->data;
			}
			flag = 1;
		}
		else
		{
			for (int j = eachlevel[i].size()-1; j >= 0; j--)
			{
				cout << ' ' << eachlevel[i][j]->data;
			}
			flag = 0;
		}
	}
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值