Anti_SG博弈,SJ定理_______John( POJ 3480 )

Description

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

Input

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

Output

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

Sample Input

2
3
3 5 1
1
1

Sample Output

John
Brother


题意:

有n堆石子,每堆石子的个数已知,两个人轮流从某个石堆取石子,至少去取一个,最多将该堆石子取完。谁取完最后一个石子谁输。

问先手比赢还是后手比赢?


分析:

明显的Anti_SG游戏,而且模型还是使用的nim游戏模型,根据SJ定理可以得到将所有石堆的sg值异或起来为ans,所有石堆的sg值中大于1的石堆个数为cnt.

先手比赢当且仅当  ans != 0 && cnt > 0 ||  ans == 0 && cnt == 0


如果对Anti_SG游戏或者SJ定理不了解的请看这里 :    虚位以待。



代码:

#include<stdio.h>
#include<string.h>

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,step,ans,flag;
        flag = 0;ans = 0;
        scanf("%d",&n);
        for(int i = 0 ; i < n ; i ++)
        {
            scanf("%d",&step);
            if(step > 1) flag ++;
            ans ^= step;
        }
        if(ans == 0 && flag == 0 || ans != 0 && flag != 0)
            printf("John\n");
        else
            printf("Brother\n");
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值