poj Prime Cuts 1595 (素数打表 选择性素数输出)

22 篇文章 0 订阅
Prime Cuts
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10948 Accepted: 4160

Description

A prime number is a counting number (1, 2, 3, ...) that is evenly divisible only by 1 and itself. In this problem you are to write a program that will cut some number of prime numbers from the list of prime numbers between (and including) 1 and N. Your program will read in a number N; determine the list of prime numbers between 1 and N; and print the C*2 prime numbers from the center of the list if there are an even number of prime numbers or (C*2)-1 prime numbers from the center of the list if there are an odd number of prime numbers in the list.

Input

Each input set will be on a line by itself and will consist of 2 numbers. The first number (1 <= N <= 1000) is the maximum number in the complete list of prime numbers between 1 and N. The second number (1 <= C <= N) defines the C*2 prime numbers to be printed from the center of the list if the length of the list is even; or the (C*2)-1 numbers to be printed from the center of the list if the length of the list is odd.

Output

For each input set, you should print the number N beginning in column 1 followed by a space, then by the number C, then by a colon (:), and then by the center numbers from the list of prime numbers as defined above. If the size of the center list exceeds the limits of the list of prime numbers between 1 and N, the list of prime numbers between 1 and N (inclusive) should be printed. Each number from the center of the list should be preceded by exactly one blank. Each line of output should be followed by a blank line. Hence, your output should follow the exact format shown in the sample output.

Sample Input

21 2
18 2
18 18
100 7

Sample Output

21 2: 5 7 11

18 2: 3 5 7 11

18 18: 1 2 3 5 7 11 13 17

100 7: 13 17 19 23 29 31 37 41 43 47 53 59 61 67
//题意:
给出两个数n、m.先算出1--n之间的素数个数num,若num为奇数则输出2*m-1个素数。否则输出2*m个素数。输出的这些素数都是从中间往两边扩散的。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 1010
using namespace std;
int p[N];
bool pp[N];
int pnum;
int getp()//素数打表 
{
	int i,j;
	memset(pp,false,sizeof(pp));
	for(i=2;i<N;i++)
	{
		if(!pp[i])
			p[pnum++]=i;
		for(j=0;j<pnum&&p[j]*i<N;j++)
		{
			pp[p[j]*i]=true;
			if(i%p[j]==0)
				break;
		}
	}
	pp[0]=true;
}
int main()
{
	int n,m,num,cnt;
	int i,j;
	getp();
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		num=0;			
		for(i=1;i<=n;i++)
		{
			if(!pp[i])
				num++;
		}
		if(num&1)
			cnt=2*m-1;
		else
			cnt=2*m;
		printf("%d %d: ",n,m);
		if(cnt>=num)
		{
			printf("1");//在这里1也是素数,而打表里没有1. 
			for(i=0;i<num-1;i++)
				printf(" %d",p[i]);
				printf("\n\n");
		}
		else
		{
			if(num&1)
			{
				printf("%d",p[num/2-m]);
				for(i=num/2-m+1;i<num/2+m-1;i++)
					printf(" %d",p[i]);
					printf("\n\n");
			}
			else
			{
				printf("%d",p[num/2-m-1]);
				for(i=num/2-m;i<num/2+m-1;i++)
					printf(" %d",p[i]);
					printf("\n\n");
			}
		}
	}
	return 0;
}
//另一种打表::
#include<stdio.h>
#include<string.h>
#define N 1010
int p[N];
bool pp[N];
int pnum;
int getp()
{
	int i,j;
	memset(pp,false,sizeof(pp));
	p[pnum++]=1;
	for(i=2;i<N;i++)
	{
		if(!pp[i])
		{
			for(j=i*2;j<N;j+=i)
				pp[j]=true;
			p[pnum++]=i;
		}
	}
} 
int main()
{
	int n,m,num,cnt;
	int i,j;
	getp();
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		num=0;			
		for(i=1;i<=n;i++)
		{
			if(!pp[i])
				num++;
		}
		if(num&1)
			cnt=2*m-1;
		else
			cnt=2*m;
		printf("%d %d: ",n,m);
		if(cnt>=num)
		{
			printf("%d",p[0]);//在这里1也是素数,而打表里没有1. 
			for(i=1;i<num;i++)
				printf(" %d",p[i]);
				printf("\n\n");
		}
		else
		{
			if(num&1)
			{
				printf("%d",p[num/2-m+1]);
				for(i=num/2-m+2;i<=num/2+m-1;i++)
					printf(" %d",p[i]);
					printf("\n\n");
			}
			else
			{
				printf("%d",p[num/2-m]);
				for(i=num/2-m+1;i<num/2+m;i++)
					printf(" %d",p[i]);
					printf("\n\n");
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值