【容斥原理-求区间内与n互质的数】HDOJ Co-prime 4135



Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2590    Accepted Submission(s): 984


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
      
      
2 1 10 2 3 15 5
 

Sample Output
      
      
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 

Source
 


题意:

求 [ a , b ] 之间与n互质的数的个数。

解题思路:

给以转换成求[1,b]中与n互质的数个数减去[1,a-1]与n互质的数的个数。

利用容斥原理:n/2+n/3+n/5-n/(2*3)-n/(2*5)-n/(3*5)+n/(2*3*5)。

有篇文章讲得不错:点击打开链接

AC代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

typedef long long LL;

LL divisor[100];
LL tot;

void Get_divisor(LL N)
{
    memset(divisor,0,sizeof(divisor));
    for(LL i=2;i*i<=N;i++){
        if(N&&(N%i==0)){
            divisor[tot++]=i;
            while(N&&(N%i==0)) N/=i;
        }
    }
    if(N>1) divisor[tot++]=N;
}

LL Get_num(LL num,LL m)
{
    LL ans=0;
    for(LL i=1;i<(1<<m);i++){
        LL temp=1,flag=0;
        for(LL j=0;j<m;j++){
            if(i&(1<<j)){
                flag++;
                temp*=divisor[j];
            }
        }
        if(flag&1)ans+=num/temp;
        else ans-=num/temp;
    }
     return ans;
}

int main()
{
    int t;
    int xp=1;
    scanf("%d",&t);
    while(t--){
        LL a,b,n;
        scanf("%lld%lld%lld",&a,&b,&n);
        tot=0;
        Get_divisor(n);
        printf("Case #%d: %lld\n",xp++,(b-Get_num(b,tot))-(a-1-Get_num(a-1,tot)));

    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值