【博弈】HDOJ ZYB's Game 5591

ZYB's Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 285    Accepted Submission(s): 238


Problem Description
ZYB  played a game named  NumberBomb  with his classmates in hiking:a host keeps a number in  [1,N]  in mind,then 
players guess a number in turns,the player who exactly guesses  X  loses,or the host will tell all the players that
the number now is bigger or smaller than  X .After that,the range players can guess will decrease.The range is  [1,N]  at first,each player should guess in the legal range.

Now if only two players are play the game,and both of two players know the  X ,if two persons all use the best strategy,and the first player guesses first.You are asked to find the number of  X  that the second player
will win when  X  is in  [1,N] .
 

Input
In the first line there is the number of testcases  T .

For each teatcase:

the first line there is one number  N .

1T100000 , 1N10000000
 

Output
For each testcase,print the ans.
 

Sample Input
  
  
1 3
 

Sample Output
  
  
1
 

Source
 


解题思路:

举例就会发现规律了。

AC代码:

#include <stdio.h>

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        if(n&1)printf("1\n");
        else printf("0\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值