hdoj 5591 ZYB's Game 【水题】

ZYB's Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 20    Accepted Submission(s): 15


Problem Description
ZYB  played a game named  NumberBomb  with his classmates in hiking:a host keeps a number in  [1,N]  in mind,then 
players guess a number in turns,the player who exactly guesses  X  loses,or the host will tell all the players that
the number now is bigger or smaller than  X .After that,the range players can guess will decrease.The range is  [1,N]  at first,each player should guess in the legal range.

Now if only two players are play the game,and both of two players know the  X ,if two persons all use the best strategy,and the first player guesses first.You are asked to find the number of  X  that the second player
will win when  X  is in  [1,N] .
 

Input
In the first line there is the number of testcases  T .

For each teatcase:

the first line there is one number  N .

1T100000 , 1N10000000
 

Output
For each testcase,print the ans.
 

Sample Input
  
  
1 3
 

Sample Output
  
  
1
 


找规律:奇数为1,偶数为0。

AC代码:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <vector>
#define INF 0x3f3f3f
#define eps 1e-8
#define MAXN (100+10)
#define MAXM (100000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
int main()
{
    int t; Ri(t);
    W(t)
    {
        int n; Ri(n);
        if(n & 1)
            printf("1\n");
        else
            printf("0\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值