UVA - 10891 Game of Sum(区间dp)

原题:

This is a two player game. Initially there are n integer numbers in an array and players A and B get

chance to take them alternatively. Each player can take one or more numbers from the left or right end

of the array but cannot take from both ends at a time. He can take as many consecutive numbers as
he wants during his time. The game ends when all numbers are taken from the array by the players.
The point of each player is calculated by the summation of the numbers, which he has taken. Each
player tries to achieve more points from other. If both players play optimally and player A starts the
game then how much more point can player A get than player B?
Input
The input consists of a number of cases. Each case starts with a line specifying the integer n (0 <
n 100), the number of elements in the array. After that, n numbers are given for the game. Input is
terminated by a line where n = 0.
Output
For each test case, print a number, which represents the maximum difference that the first player
obtained after playing this game optimally.
Sample Input
4
4 -10 -20 7
4
1 2 3 4
0
Sample Output
7
10


题意:
        长度为n的整数序列中,A和B轮流从左或右端取任意数量的数字,直至全部数字被取完,每人每次采取最优策略使自己取得数字总和最大,A先取,结束时A取数字总和与B取数字总和的差。

思路:
       任意时刻游戏状态均为原序列的一段子序列,A,B取得数字总和为序列总和。则取dp[i][j]为子序列为i~j时,A取得最大数字和。dp[i][j]=sum(i,j)-min{dp[i+1][j],dp[i+1][j],…,dp[j][j],dp[i][j-1],dp[i][j-2],…,dp[i][i],0},为从左端或从右端或全部取走时的最大数字和。令l[i][j]为左端开始取,r[i][j]为从右端开始取。dp[i][j]=sum(i,j)-min{l[i+1][j],r[i][j-1],0}。l[i][j]=min{dp[i][j],l[i+1][j]},r[i][j]=min{dp[i][j],r[i][j-1]}。

       A,B两人得分和为sum(0,n-1),则dp[0][n-1]-(sum(0,n-1)-dp[0][n-1])=2*dp[0][n-1]-sum(0,n-1)。


#include <iostream>
#include <iomanip>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <deque>
#include <string>
#include <cmath>
#include <vector>
#include <utility>
#include <set>
#include <climits>
//#pragma comment(linker, "/STACK:1024000000,1024000000")
#define INF 2147483647
using namespace std;
typedef long long ll;
int s[105],sum[105];
int n,i,j,k;
int dp[105][105];
int l[105][105],r[105][105];
int main()
{
    while(scanf("%d",&n)&&n)
    {
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));
        memset(sum,0,sizeof(sum));
        memset(s,0,sizeof(s));
        memset(dp,0,sizeof(dp));
        for(i=0;i<n;i++)
        {
            scanf("%d",&s[i]);
            if(i==0)
                sum[i]=s[i];
            else
                sum[i]=sum[i-1]+s[i];
        }
        for(i=0;i<n;i++)
            l[i][i]=r[i][i]=dp[i][i]=s[i];
        for(int L=1;L<=n;L++)//枚举序列长度
            for(i=0;i+L<n;i++)
        {
            j=i+L;
            int m=0;
            m=min(m,l[i+1][j]);
            m=min(m,r[i][j-1]);
            if(i>0)
            dp[i][j]=sum[j]-sum[i-1]-m;
            else
                dp[i][j]=sum[j]-m;
            l[i][j]=min(dp[i][j],l[i+1][j]);
            r[i][j]=min(dp[i][j],r[i][j-1]);
        }
        printf("%d\n",2*dp[0][n-1]-sum[n-1]);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值