【斐波那契应用】HDOJ KK's Steel 5620



KK's Steel

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 497    Accepted Submission(s): 236


Problem Description
Our lovely KK has a difficult mathematical problem:he has a  N(1N1018)  meters steel,he will cut it into steels as many as possible,and he doesn't want any two of them be the same length or any three of them can form a triangle.
 

Input
The first line of the input file contains an integer  T(1T10) , which indicates the number of test cases.

Each test case contains one line including a integer  N(1N1018) ,indicating the length of the steel.
 

Output
For each test case, output one line, an integer represent the maxiumum number of steels he can cut it into.
 

Sample Input
      
      
1 6
 

Sample Output
      
      
3
Hint
1+2+3=6 but 1+2=3 They are all different and cannot make a triangle.
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5634  5633  5632  5631  5630 
 


题意:

题意简单。。。

解题思路:

开始以为是个规律,直接除2了。。。。。。。wa了发现不对。。斐波那契数列,因为为了保持后边的数尽可能小,所以最大就等于前面的2个数相加。。这样一直下去就是斐波那契数列了。。

AC代码:

#include <stdio.h>

using namespace std;

typedef long long LL;

LL f[1000];

int main()
{
	f[0]=1;f[1]=2;
	for(int i=2;i<1000;i++){
		f[i]=f[i-1]+f[i-2];
	}
    int t;
    scanf("%d",&t);
    while(t--){
        LL n;
        scanf("%lld",&n);
        int i;
        LL ans=0;
        for(i=0;ans<=n;i++){
        	ans+=f[i];
		}
		if(ans>n)i--;
		printf("%d\n",i);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值