hdoj 5620 KK's Steel 【数学】

KK's Steel

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 253    Accepted Submission(s): 120


Problem Description
Our lovely KK has a difficult mathematical problem:he has a  N(1N1018)  meters steel,he will cut it into steels as many as possible,and he doesn't want any two of them be the same length or any three of them can form a triangle.
 

Input
The first line of the input file contains an integer  T(1T10) , which indicates the number of test cases.

Each test case contains one line including a integer  N(1N1018) ,indicating the length of the steel.
 

Output
For each test case, output one line, an integer represent the maxiumum number of steels he can cut it into.
 

Sample Input
  
  
1 6
 

Sample Output
  
  
3
Hint
1+2+3=6 but 1+2=3 They are all different and cannot make a triangle.
 


题意:给你一根长n的木条,要求你截取若干个不等长的木条且任意三个都不能组成三角形,问最多截多少条。


思路:就是一个斐波那契,以前做过类似的题目。


AC代码:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <string>
#define INF 1000000
#define eps 1e-8
#define MAXN (10000+10)
#define MAXM (10000+10)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while((a)--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
#define PI acos(-1.0)
#pragma comment(linker, "/STACK:102400000,102400000")
#define fi first
#define se second
using namespace std;
typedef pair<int, int> pii;
LL f[1001];
void getf()
{
    f[1] = 1; f[2] = 2;
    for(int i = 3; i <= 1000; i++)
        f[i] = f[i-1] + f[i-2];
}
int main()
{
    getf();
    int t; Ri(t);
    W(t)
    {
        LL n; scanf("%I64d", &n);
        LL sum = 0; int i;
        for(i = 1; i <= 1000; i++)
        {
            sum += f[i];
            if(sum >= n) break;
        }
        if(sum != n) i--;
        Pi(i);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值