hdu1009 FatMouse' Trade(贪心)

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51313    Accepted Submission(s): 17182


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
 

Author
CHEN, Yue
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1050  1051  1052  1010  1049 
 
解析:贪心。
           按照每个房间的 j[i]/f[i] 的值,有大到小进行排序,从最大的开始,能卖多少就买多少,直到买完为止。
           需要注意的是,有的房间的 f[i] 为 0 的情况,就是不要猫粮,直接白送(我靠,真是一只好猫,跟老鼠做交易就算了,还白送,我要是主人的话,我保证绝对不打死它)。

代码:
#include<cstdio>
#include<algorithm>
#define maxn 1000
using namespace std;

struct tnode{int x,y;double z;};
tnode a[maxn+20];

bool cmp(tnode p,tnode q)
{
  return p.z>q.z;
}

int main()
{
  freopen("1.in","r",stdin);
  int m,n,i,j,k,sum; double ans;
  while(scanf("%d%d",&m,&n)&&m!=-1)
    {
      ans=0,sum=0;
      for(i=1;i<=n;i++)
        {
          scanf("%d%d",&j,&k);
          if(k==0){ans+=j;continue;}
          a[++sum].x=j,a[sum].y=k;
          a[sum].z=j*1.0/k;
        }
      sort(a+1,a+sum+1,cmp);  
      for(i=1;m>=0 && i<=sum;i++)
        {
          k=min(m,a[i].y);
          ans+=a[i].z*k;
          m-=k;
        }
      printf("%.3lf\n",ans);  
    }
  return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值