hdu 1009 FatMouse' Trade 贪心

 
 
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500
翻译:老鼠准备了M磅的猫粮,去和每个房间里的猫去换取JB,但是每个房间同等重量的猫粮,换取不同重量的JB,给你老鼠总共有的猫粮的重量,和房间数,接下来每行两个数是这个房间,给的猫粮数和能换出的JB数。
这是一道贪心题,既然要贪心的话,就要贪同等质量的猫粮能换出最多JB,所以就要求每个房间同等的猫粮能换出JB的比例,排序,先去比例高的房间去换,依次直到把自己的猫粮换完。

#include<stdio.h>
struct food
{
  double b,j,f;
}mo[1001];
int main()
{
  int m,n,i,k;
  double t,get;
  while(scanf("%d%d",&m,&n)!=EOF)
  {
    get=0;
    if(m==-1 && n==-1)
      break;
    for(i=0;i<n;i++)
    {
      scanf("%lf%lf",&mo[i].j,&mo[i].f);
      mo[i].b=(mo[i].j/mo[i].f);
    }
     for(i=0;i<n;i++)
     {
       for(k=i+1;k<n;k++)
       {
         if(mo[k].b>mo[i].b)
         {
           t=mo[i].b;
           mo[i].b=mo[k].b;
           mo[k].b=t;
           t=mo[i].f;
           mo[i].f=mo[k].f;
           mo[k].f=t;
           t=mo[i].j;
           mo[i].j=mo[k].j;
           mo[k].j=t;


         }
       }
     }
     
     for(i=0;i<n;i++)
     {
        if(m>=mo[i].f)
        {
            m-=mo[i].f;
            get+=mo[i].j;
        }

        else
        {
          get+=(m*mo[i].b);
          m=0;
          break;
        }

     }
     printf("%0.3lf\n",get);
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值