NY Radar

Radar

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1
 
   
思路:
   简单的贪心,只要想到将二维转化为一维的数轴就和普通的贪心一样。
我的代码:
 
   
#include<iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
struct S 
{
	double L,R;
}a[1010];
bool cmp(const S& a ,const S& b)
{
	return a.R<b.R;
}
int main()
{
	int n,m,i,j,flag,count=0;
	double x,y,k;
	while (~scanf("%d %d",&n,&m))
	{
		count++;
		if (n==0&&m==0)
		{
			break;
		}
		for (i=0,flag=0;i<n;++i)
		{
			scanf("%lf %lf",&x,&y);
			if (y>m)
			{
				flag=1;
			}
			a[i].L = x-sqrt(m*m-y*y);
			a[i].R = x+sqrt(m*m-y*y);
		}
		if (flag)
		{
			printf("-1\n");
			continue;
		}
		sort(a,a+n,cmp);
		k=a[0].R;
		for (i=0,j=1;i<n;++i)
		{
			if (k<a[i].L)
			{
				j++;
				k=a[i].R;
			}
		}
		printf("Case %d: ",count);
		printf("%d\n",j);
	}
	return 0;
}

标程:
 
   
 
 
#include<iostream>
#include<algorithm>
#include<climits>
#include<cmath>
using namespace std;
int r;
struct Island
{
	double x,y;
	double Left() const {if(y>r)throw -1;return x-sqrt(r*r-y*y);}
	double Right() const {if(y>r)throw -1;return x+sqrt(r*r-y*y);}
};
const int MAX=1010;
Island lands[MAX];
bool sortby(const Island& i1,const Island& i2)
{
	return i1.Right()<i2.Right();
}
int main()
{

	int n,num,cn=0;
	double start;
	while(cin>>n>>r)
	{
		num=0;start=-1e100;
		try{
			if(n==0 && r==0) break;
			for(int i=0;i!=n;++i)
			{
				cin>>lands[i].x>>lands[i].y;
			}
			sort(lands,lands+n,sortby);
		
			for(int i=0;i!=n;i++)
				if(lands[i].Left()>start) {start=lands[i].Right();++num;}
			cout<<"Case "<<++cn<<": "<<num<<endl;
		}
		catch(...)
		{
			cout<<"Case "<<++cn<<": "<<-1<<endl;
		}
	}

}                


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值