Radar Installation(贪心。 区间选点)

Radar Installation

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 8   Accepted Submission(s) : 2
Problem Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


 

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. <br> <br>The input is terminated by a line containing pair of zeros <br>
 

Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
 

Sample Input
  
  
3 2 1 2 -3 1 2 1 1 2 0 2 0 0
 

Sample Output
  
  
Case 1: 2 Case 2: 1
 

题意,地图上有若干岛,雷达放置在x轴,求最少用几个雷达就可以把所有的岛覆盖。

1、y > d的情况直接就输出-1
2、用 勾股定理, 求出左右x的范围 x^2 = d^2 - y^2;
然后就可以放心贪心了。
#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
#include <set>
#include <cmath>
#include <queue>
using namespace std;
    //const int INF = 0x3fffffff;
int n;
double d;
struct Node {
    double left, right;
}node[1010];
bool cmp(const Node& n1, const Node& n2) {
    return n1.right < n2.right || (n1.right == n2.right && n1.left > n2.left);
}
int find(double pos) {
    int ans = 1;
    for (int i = 1; i < n; ++i) {
        if (node[i].left > pos) {
            pos = node[i].right;
            ans++;
        }
    }
    return ans;
}
int main() {
        //freopen("in.txt", "r", stdin);
    int t = 0;
    int flag = 0;
    while (scanf("%d%lf",&n,&d) != EOF && (n + d)) {
        
        flag = 0;
        double x, y;
        for (int i = 0; i < n; ++i) {
            scanf("%lf%lf",&x,&y);
            if (y > d) {
                flag = 1;
            }
            node[i].left = x - sqrt(d*d - y*y);
            node[i].right = x + sqrt(d*d - y*y);
        }
        if (flag) {
            printf("Case %d: %d\n",++t,-1);
        } else {
            sort(node, node + n, cmp);
            printf("Case %d: %d\n",++t,find(node[0].right));
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值