HPUOJ--2017寒假作业-专题0/Q-Radar Installation

Q - Radar Installation

 

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1
 
   
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std; 
struct il
{
double x;
double y;
double p;
double st;
double endd; 
}data[1000+11];
bool cmp1(il A,il B)
{
return A.endd<B.endd;
}
bool cmp2(il A,il B)
{
return A.y>B.y;
}
int main()
{
	int n,i,m,num=0,t=0;
	double d,q;
	while(scanf("%d%lf",&n,&d),n!=0||d!=0)
	{
		t++;
		num=1;
		for(i=0;i<n;i++)
		{
			scanf("%lf%lf",&data[i].x,&data[i].y);
		}
		sort(data,data+n,cmp2);
		if(data[0].y>d)
		    m=0;
		else
		{
			m=1;
			for(i=0;i<n;i++)
			{
				data[i].p=sqrt(d*d-data[i].y*data[i].y);
				data[i].st=data[i].x-data[i].p;
				data[i].endd=data[i].x+data[i].p;
			}
		    sort(data,data+n,cmp1);
		    q=data[0].endd;
		    for(i=1;i<n;i++)
		    {
				if (data[i].st > q)		//此雷达覆盖范围外 ,就是说只要能被原来的雷达覆盖就不用添加,一旦不能被覆盖就要添加啦,这个时候再来更新q,只管不能覆盖的就好啦。嘿嘿 。 
				{
					num++;		//加一个新雷达 
					q = data[i].endd;		//尽量靠后放 
				}
		    }
		}
		if(m==0)
		    printf("Case %d: -1\n",t);
		else if(m==1)
		    printf("Case %d: %d\n",t,num); 
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值