AtCoder Beginner Contest 336 A题解

Problem Statement

For a positive integer �X, the Dragon String of level �X is a string of length (�+3)(X+3) formed by one L, �X occurrences of o, one n, and one g arranged in this order.

You are given a positive integer �N. Print the Dragon String of level �N.
Note that uppercase and lowercase letters are distinguished.

Constraints

  • 1≤�≤20241≤N≤2024
  • �N is an integer.

Input

The input is given from Standard Input in the following format:

�N

Output

Print the Dragon String of level �N.


Sample Input 1Copy

Copy

3

Sample Output 1Copy

Copy

Looong

Arranging one L, three os, one n, and one g in this order yields Looong.


Sample Input 2Copy

Copy

1

Sample Output 2Copy

Copy

Long

太水了

#include<iostream>
using namespace std;
int main(){
  int a;
  cin>>a;
  cout<<"L";
  for(int i=1;i<=a;i++){
    cout<<"o";
  }
  cout<<"ng";
  return 0;
}

  • 8
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值