C语言学习:PTA 7-55 查询水果价格

给定四种水果,分别是苹果(apple)、梨(pear)、桔子(orange)、葡萄(grape),单价分别对应为3.00元/公斤、2.50元/公斤、4.10元/公斤、10.20元/公斤。

首先在屏幕上显示以下菜单:

[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
用户可以输入编号1~4查询对应水果的单价。当连续查询次数超过5次时,程序应自动退出查询;不到5次而用户输入0即退出;输入其他编号,显示价格为0。

输入格式:
输入在一行中给出用户连续输入的若干个编号。

输出格式:
首先在屏幕上显示菜单。然后对应用户的每个输入,在一行中按格式“price = 价格”输出查询结果,其中价格保留两位小数。当用户连续查询次数超过5次、或主动输入0时,程序结束。

输入样例1:
3 -1 0 2
输出样例1:
[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
price = 4.10
price = 0.00
输入样例2:
1 2 3 3 4 4 5 6 7 8
输出样例2:
[1] apple
[2] pear
[3] orange
[4] grape
[0] exit
price = 3.00
price = 2.50
price = 4.10
price = 4.10
price = 10.20

方法一(用字符数组存放数据):

#include<stdio.h>

int main()
{
	int i = 0;
	char a[10086];
	gets(a);//输入字符数组。
	printf("[1] apple\n[2] pear\n[3] orange\n[4] grape\n[0] exit\n");
	for (i = 0; i < 9; i++)
	{
		if (a[i] == '0')
		{
			break;
		}
		switch (a[i])
		{
		case '1':printf("price = 3.00\n"); break;//因为是字符所以要加''。
		case '2':printf("price = 2.50\n"); break;
		case '3':printf("price = 4.10\n"); break;
		case '4':printf("price = 10.20\n"); break;
		case ' ':break;
		default:printf("price = 0.00\n"); break;
		}
	}
	return 0;
}

不过,可以VS 2022上可以运行,但却不能再PTA的编译器中运行。初步猜测是因为使用gets输入字符数组。

 

 

方法二(用整型数组存放数据):

#include<stdio.h>

int main()
{
	int i = 0;
	int a[10086] = { 0 };
	for (i = 0; a[i]<5;i++)
	{
		scanf("%d", &a[i]);
		if (a[i] == 0)
		{
			break;
		}
	}
	printf("[1] apple\n[2] pear\n[3] orange\n[4] grape\n[0] exit\n");
	for (i = 0; i < 5; i++)
	{
		switch (a[i])
		{
		case 1:printf("price = 3.00\n"); break;
		case 2:printf("price = 2.50\n"); break;
		case 3:printf("price = 4.10\n"); break;
		case 4:printf("price = 10.20\n"); break;
		case 0:break;
		default:printf("price = 0.00\n"); break;
		}
	}

	return 0;
}

  • 4
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值