7-49 Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

代码实现:

#include<stdio.h>
#include<string.h>
int main()
{
char ch1[23]="";
int num1[23],num2[23];
    int digit1[10]={0},digit2[10]={0};
    int flag=1;
    scanf("%s",ch1);
    int len1=strlen(ch1);
    int len2=len1;
    int i,j,k;
    for(i=len1-1;i>=0;i--)
    {
        num1[len1-i-1]=ch1[i]-'0';
    }
    for(i=0;i<len1;i++)
    {
        digit1[num1[i]]++;
    }
    for(j=0;j<len1;j++)
    {
        num2[j]=num1[j]*2;
    }
    for(j=0;j<len1-1;j++)
    {
        if(num2[j]>9)
        {
            num2[j+1]+=num2[j]/10;
            num2[j]%=10;
        }
    }
if(num2[len1]==1)
{
    len2++;
}
    for(i=0;i<len2;i++)
    {
        digit2[num2[i]]++;
    }
for(k=0;k<10;k++)
{
    if(digit1[k]!=digit2[k])
    {
        flag=0;
        break;
    }
}

    if(flag==0)
    {
        printf("No\n");
    }
    else
    {
        printf("Yes\n");
    }
    for(j=len2-1;j>=0;j--)
        {
            printf("%d",num2[j]);
        }
        printf("\n");
return 0;}

  • 3
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值