Lake Counting AC代码 深搜(带注释)

描述

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

输入

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

输出

* Line 1: The number of ponds in Farmer John's field.

样例输入

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

样例输出

3

AC代码:

#include <bits/stdc++.h>
using namespace std;

int dx[8]={-1,-1,-1,0,1,1,1,0};//八个方向
int dy[8]={-1,0,1,1,1,0,-1,-1};

int bz[105][105],num=0;
int m,n;

void dfs(int p,int q)//dfs函数 
{
    int i,x,y;
	bz[p][q]=0;
	for(i=0;i<=7;i++)//八个方向
	{
	   x=p+dx[i];
	   y=q+dy[i];
	   if(x>=0&&x<m&&y>=0&&y<n&&bz[x][y])//判断条件
	   {
			dfs(x,y);//递归
	   }
	} 
	return;
}


int main() 
{ 
	int i,j;
	char s[105],ch;
	scanf("%d%d",&m,&n);//将01图所有的变为1 
	for(i=0;i<=m-1;i++)
		for(j=0;j<=n-1;j++)
			bz[i][j]=1;
			
	for(i=0;i<=m-1;i++)
	{
		scanf("%s",s);//输入每一个字符 
		for(j=0;j<=n-1;j++)
			if(s[j]=='.')bz[i][j]=0;
	}
	
//	for(i=0;i<=m-1;i++)
//	{
//		for(j=0;j<=n-1;j++)
//			cout<<bz[i][j];
//		cout<<endl;
//	}
	
	for(i=0;i<=m-1;i++)
		for(j=0;j<=n-1;j++)
			if(bz[i][j])
			{
				dfs(i,j);//dfs递归 
				num++;//数量加加
			}
			
	printf("%d",num);   //完美输出
	return 0; 
} 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值