P1601 A+B Problem(高精)

A+B Problem(高精)

题目描述

高精度加法,相当于 a+b problem,不用考虑负数

输入格式

分两行输入。 a , b ≤ 1 0 500 a,b \leq 10^{500} a,b10500

输出格式

输出只有一行,代表 a + b a+b a+b 的值。

样例 #1

样例输入 #1

1
1

样例输出 #1

2

样例 #2

样例输入 #2

1001
9099

样例输出 #2

10100

code:

#include<bits/stdc++.h>
using namespace std;
struct BigInteger
{
    static const int BASE = 100000000;
    static const int WIDTH = 8;
    vector<int> s;
    BigInteger(long long num = 0) { *this = num; } 
    BigInteger operator = (long long num)
	{
    	s.clear();
    	do{
			s.push_back(num % BASE);
    		num/=BASE;
    	}while(num > 0);
    	return *this;
    }
    BigInteger operator = (const string& str) 
	{ 
    	s.clear();
    	int x, len = (str.length() - 1) / WIDTH + 1;
    	for(int i = 0; i < len; i++)
    	{
    		int end = str.length() - i*WIDTH;
    		int start = max(0, end - WIDTH);
    		sscanf(str.substr(start, end-start).c_str(), "%d", &x);
    		s.push_back(x);
    	}
    	return *this;
    }
  	BigInteger operator + (const BigInteger& b) 
	{
   		BigInteger c;
    	c.s.clear();
    	for(int i = 0, g = 0; ; i++)
		{
      		if(g == 0 && i >= s.size() && i >= b.s.size()) break;
      		int x = g;
      		if(i < s.size()) x += s[i];
      		if(i < b.s.size()) x += b.s[i];
      		c.s.push_back(x % BASE);
      		g = x / BASE;
    	}
    	return c;
   }
};

ostream& operator << (ostream &out, const BigInteger& x)
{
    out << x.s.back();
    for(int i = x.s.size()-2; i >= 0; i--) 
	{
    	char buf[20];
    	sprintf(buf, "%08d", x.s[i]);
    	for(int j = 0; j < strlen(buf); j++) out << buf[j];
    }
    return out;
}
istream& operator >> (istream &in, BigInteger& x)
{
    string s;
    if(!(in >> s)) return in;
    x = s;
    return in;
}
int main() 
{
    BigInteger a,b;
    cin>>a>>b;
    cout<<a+b;
    return 0;
}

刘爷爷的高精加法,具体应用了压位高精,把一个数拆分成多个八位数的形式,再进行加减

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值