Simple

「Daily OI Round 3」Simple

题目背景

这是一道简单题。

题目描述

Acoipp 的某个软件的账号叫做 Svpoll,并且这款软件的账号与洛谷账号均不区分大小写,例如 SVPOLl \texttt{SVPOLl} SVPOLl svPOLL \texttt{svPOLL} svPOLL 等价, aCoIPp \texttt{aCoIPp} aCoIPp Acoipp \texttt{Acoipp} Acoipp 等价。

现在你想要知道某个账号名称是与 Acoipp \texttt{Acoipp} Acoipp 等价,还是与 Svpoll \texttt{Svpoll} Svpoll 等价,或者是与前两者都不等价。

输入格式

一行一个字符串,表示账号名称。

输出格式

一行一个字符串,如果输入的字符串与 Acoipp \texttt{Acoipp} Acoipp 等价,那么输出 Luogu \texttt{Luogu} Luogu;如果输入的字符串与 Svpoll \texttt{Svpoll} Svpoll 等价,那么输出 Genshin \texttt{Genshin} Genshin;如果输入的字符串与前两者都不等价,输出 Boring \texttt{Boring} Boring

样例 #1

样例输入 #1

SVPOLL

样例输出 #1

Genshin

样例 #2

样例输入 #2

ACoiPP

样例输出 #2

Luogu

样例 #3

样例输入 #3

RECOLL

样例输出 #3

Boring

提示说明

【样例解释 #1】

因为不区分大小写,所以 SVPOLL \texttt{SVPOLL} SVPOLL 中的 V \texttt{V} V P \texttt{P} P O \texttt{O} O L \texttt{L} L 分别与 v \texttt{v} v p \texttt{p} p o \texttt{o} o l \texttt{l} l 等价,所以 SVPOLL \texttt{SVPOLL} SVPOLL Svpoll \texttt{Svpoll} Svpoll 等价。

【数据范围】

∣ S ∣ |S| S 为字符串长度,对于全部数据保证: ∣ S ∣ = 6 |S|=6 S=6 并且输入的字符串只包含大小写英文字母。

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

int main()
{
    string a;
    cin>>a;
    
    for(ll i=0;i<6;i++)
        a[i]=toupper(a[i]);//转换
    
    if(a=="SVPOLL") cout<<"Genshin";
    else if(a=="ACOIPP") cout<<"Luogu";
    else cout<<"Boring";
    
    return 0;
}
  • 20
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值