求小数的某一位

求小数的某一位

题目描述

分数 a b \dfrac{a}{b} ba 化为小数后,小数点后第 n n n 位的数字是多少?

输入格式

三个正整数 a a a b b b n n n,相邻两个数之间用单个空格隔开。 0 < a ≤ b ≤ 100 0<a\le b\le100 0<ab100 1 ≤ n ≤ 10000 1 \le n \le 10000 1n10000

输出格式

一个数字。

样例 #1

样例输入 #1

1 2 1

样例输出 #1

5

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//堆/优先队列
// #include <queue>//队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

int main()
{
    ll a,b,n;
    cin>>a>>b>>n;
    
    for(ll i=1;i<=n;i++)
    {
        a%=b;
        a*=10;
    }
    
    a/=b;
    cout<<a<<endl;
    
    return 0;
} 
  • 2
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值