Competitive Programmer

Competitive Programmer

题面翻译

给出 n n n个数,问对于每个数,是否可以将这个数的数位重新组合(可以有前导零),使其可以被 60 60 60整除,若可以,则输出 r e d red red,否则,输出 c y a n cyan cyan

题目描述

Bob is a competitive programmer. He wants to become red, and for that he needs a strict training regime. He went to the annual meeting of grandmasters and asked $ n $ of them how much effort they needed to reach red.

“Oh, I just spent $ x_i $ hours solving problems”, said the $ i $ -th of them.

Bob wants to train his math skills, so for each answer he wrote down the number of minutes ( $ 60 \cdot x_i $ ), thanked the grandmasters and went home. Bob could write numbers with leading zeroes — for example, if some grandmaster answered that he had spent $ 2 $ hours, Bob could write $ 000120 $ instead of $ 120 $ .

Alice wanted to tease Bob and so she took the numbers Bob wrote down, and for each of them she did one of the following independently:

  • rearranged its digits, or
  • wrote a random number.

This way, Alice generated $ n $ numbers, denoted $ y_1 $ , …, $ y_n $ .

For each of the numbers, help Bob determine whether $ y_i $ can be a permutation of a number divisible by $ 60 $ (possibly with leading zeroes).

输入格式

The first line contains a single integer $ n $ ( $ 1 \leq n \leq 418 $ ) — the number of grandmasters Bob asked.

Then $ n $ lines follow, the $ i $ -th of which contains a single integer $ y_i $ — the number that Alice wrote down.

Each of these numbers has between $ 2 $ and $ 100 $ digits ‘0’ through ‘9’. They can contain leading zeroes.

输出格式

Output $ n $ lines.

For each $ i $ , output the following. If it is possible to rearrange the digits of $ y_i $ such that the resulting number is divisible by $ 60 $ , output “red” (quotes for clarity). Otherwise, output “cyan”.

样例 #1

样例输入 #1

6
603
006
205
228
1053
0000000000000000000000000000000000000000000000

样例输出 #1

red
red
cyan
cyan
cyan
red

提示说明

In the first example, there is one rearrangement that yields a number divisible by $ 60 $ , and that is $ 360 $ .

In the second example, there are two solutions. One is $ 060 $ and the second is $ 600 $ .

In the third example, there are $ 6 $ possible rearrangments: $ 025 $ , $ 052 $ , $ 205 $ , $ 250 $ , $ 502 $ , $ 520 $ . None of these numbers is divisible by $ 60 $ .

In the fourth example, there are $ 3 $ rearrangements: $ 228 $ , $ 282 $ , $ 822 $ .

In the fifth example, none of the $ 24 $ rearrangements result in a number divisible by $ 60 $ .

In the sixth example, note that $ 000\dots0 $ is a valid solution.

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

void solve()
{
    string s;
    cin>>s;

    ll op=0,sum=0,cnt=0;
    for(auto &t:s)
    {
        if(t=='0') op=1;
        if((t-'0')%2==0) cnt++;
        sum+=t-'0';
    }
    cnt--;

    if(op&&sum%3==0&&cnt) cout<<"red"<<endl;
    else cout<<"cyan"<<endl;
}

int main()
{
    ll t;
    cin>>t;

    while(t--) solve();

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值