【C/C++】哈理工-oj 整数翻转(hard)

Description:

给出一个不含前导0的整数,你需要将这个数字上的每位整数进行翻转

Input:

第一行为一个整数T ( T <= 1000) 表示样例个数

接下来T行每行为一个整数n (-10100000 <= n <= 10100000 )

tips:注意含有负数

Output:

每个样例输出一行,将整数翻转之后的数(不含前导0)

Sample Input:

4
0
260
10000000001
-123
Sample Output:

0
62
10000000001
-321

Hint:

注意含负数

#include<iostream>
#include<stdio.h>
#include<string>
using namespace std;
int main()
{
	int t;
	cin >> t;
	while (t--)
	{
		int flag = 1;
		string a;
		cin >> a;
		if (a == "0")
			cout << 0 << '\n';
		else if (a[0] != '-')
		{
			for (int i = a.length() - 1; i >= 0; i--)
			{
				if (flag == 1 && a[i] == '0')
				{
					continue;
				}
				else
				{
					cout << a[i];
					flag = 0;
				}
			}
			cout << '\n';
		}
		else if (a[0] == '-')
		{
			cout << '-';
			for (int i = a.length() - 1; i > 0; i--)
			{
				if (flag == 1 && a[i] == '0')
				{
					continue;
				}
				else
				{
					cout << a[i];
					flag = 0;
				}
			}
			cout << '\n';
		}
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值