Tak and Hotels I#C++

题目描述

There is a hotel with the following accommodation fee:
X yen (the currency of Japan) per night, for the first K nights
Y yen per night, for the (K+1)-th and subsequent nights
Tak is staying at this hotel for N consecutive nights. Find his total accommodation fee.

Constraints
1≤N,K≤10000
1≤Y<X≤10000
N,K,X,Y are integers.

输入

The input is given from Standard Input in the following format:
N
K
X
Y

输出

Print Tak's total accommodation fee.

样例输入 
5
3
10000
9000
样例输出 
48000
提示

The accommodation fee is as follows:
10000 yen for the 1-st night
10000 yen for the 2-nd night
10000 yen for the 3-rd night
9000 yen for the 4-th night
9000 yen for the 5-th night
Thus, the total is 48000 yen.

代码如下

#include<iostream>
using namespace std;

int main()
{
	int n, k, x, y;
	int m;
	cin >> n >> k >> x >> y;
	if (n > k)//住的天数满k天
	{
		m = k * x + (n - k) * y;
	}
	else if (n <= k)//住的天不满k天
	{
		m = n * x;
	}
	cout << m;
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Julie_Mol

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值