1002. A+B for Polynomials (25)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
题目大意: A,B是两个多项式,计算两个多项式的和。结果也是用多项式的形式表示。这里插一下多项式相加的原理:多项式的加法,是指多项式中同类项(即指数相同)的系数相加。
代码如下:
#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
double a[1100]={0},b[1100]={0};//数组下标为指数
int k;
cin>>k;
for(int i=0;i<k;i++)
{
int expo;//指数
double coef;//系数
cin>>expo>>coef;
a[expo]+=coef;
}
cin>>k;
for(int i=0;i<k;i++)
{
int expo;
double coef;
cin>>expo>>coef;
a[expo]+=coef;//多项式相加
}
int cnt=0;
for(int i=0;i<=1000;i++)if(a[i])cnt++;//非0项则项数加1
cout<<cnt;
for(int i=1000;i>=0;i--)
if(a[i])cout<<' '<<i<<' '<<fixed<<setprecision(1)<<a[i];
}