POJ-2236-Wireless Network

Wireless Network

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.
The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

题目大意:

给定n台坏掉的电脑(编号1-n),最大可联系距离为d。接下来给出每台电脑的坐标(x,y)和一系列操作。O打头的操作代表修复一台电脑,S打头的操作代表查询后面两台电脑能否联系,能则输出“SUCCESS”,不能则输出“FAIL”。

思路:

并查集。修复一台电脑后,遍历其他所有电脑,看这台电脑能否和修复的电脑联系(在距离之内并且二者均被修复)。若能,则加入同一个“集团”。最后检索两台电脑是否在同一个“集团”就可以了。
代码如下:

#include<iostream>
#include<cstdio>
using namespace std;
struct computer
{
  int x,y;//坐标
  bool fix;//是否被修复
}c[1010];
int father[1010];
int getf(int m)
{
  if(m==father[m])return m;
  else return father[m]=getf(father[m]);
}
void merge(int a,int b)
{
  int ta=getf(a);
  int tb=getf(b);
  if(ta!=tb)
    father[tb]=ta;
}
int main()
{
  int n,d;
  cin>>n>>d;
  for(int i=1;i<=n;i++)
  {
    cin>>c[i].x>>c[i].y;
    father[i]=i;
  }
  char operation[10];//输入这里要注意一下,不能是输入一个字符
  while(scanf("%s",&operation)!=EOF)
  {
    if(operation[0]=='O')
    {
      int num;
      cin>>num;
      c[num].fix=true;//修复后
      for(int j=1;j<=n;j++)
      {
        if(j==num)continue;
        int distance=(c[num].x-c[j].x)*(c[num].x-c[j].x)+//遍历所有其他的电脑
        (c[num].y-c[j].y)*(c[num].y-c[j].y);
        if(c[j].fix&&distance<=d*d)merge(num,j);//看是否能联系上,能则属于同一个集团
      }
    }
    else
    {
      int a,b;
      cin>>a>>b;
      if(getf(a)==getf(b))cout<<"SUCCESS"<<endl;//是否有同样的老大
      else cout<<"FAIL"<<endl;
    }
  }
}

需要注意的坑点就是后面对于操作输入的处理,我已开始直接输入了一个字符进去。然后出现一些奇怪的问题,暂时还没想明白这个问题,留待解决。也希望路过的大神看到后能不吝赐教。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值