HDU 1004 Let the Balloon Rise

8 篇文章 0 订阅

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 74708    Accepted Submission(s): 27975


Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

  
  
5 green red blue red red 3 pink orange pink 0

Sample Output

  
  
red pink
//题意:就是看一下哪一个颜色的频率最高
//结题报告:签到题,每输入一个字符串,如果该字符串在当前的颜色中有,那么这个颜色的数量就+1,如果没有那么
//创建这个颜色
#include<iostream>
#include<cstring>
#include<string.h>
using namespace std;
int const N = 1000;
char color[N][15];
//搜索该字符串是否存在于当前空间
int search(char a[],int total)//total是当前空间中字符串总数
{
    for(int i = 0;i < total;i ++)
    {
        if(strcmp(a,color[i]) == 0)
            return i+1;
    }
    return 0;
}
int main()
{
    char a[16];
    int T,n,total = 0;
    int result[N+1] = {0};
    int k;
 //   cin>>T;//t组测试数据
    while(cin>>n&&n)//N组字符串
    {
        total = 0; //color清零
        memset(result,0,sizeof(int)*1001);
        for(int i = 0;i < n;i++)
        {
            cin>>a;
            if(k = search(a,total))
                result[k] ++;
            else
                strcpy(color[total],a),result[total+1]++,total++;
        }
        int max = 1;
        for(int i = 1;i <= total;i++)
        {
            if(result[i] > result[max])
                max = i;
        }
        cout<<color[max-1]<<endl;
      //  for(int i = 1;i <= total;i++)
        //    cout<<color[i-1]<<' '<<result[i]<<' ';

    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值