ZOJ 2737 Occurrence

Given a string A which can be represented as A1A2..An (n is the length of A) and a string B which can be represented as B1B2..Bm (m is the length of B), you will need to find the occurrence of B from A.

The definition of occurrence is as follows:
If there exists an index p (p >= 1 and p + m <= n), and ApAp+1..Ap+m-1 matches with any rotation of B (B1B2..Bm-1Bm, B2B3..BmB1, ��, BmB1..Bm-2Bm-1 are all the rotation of B), we call it is an occurrence of B from A.

Input:

This problem contains multiple test cases. Each test case contains two lines, which are the strings A and B. The length of A is not greater then 1000 and the length of B is not greater than 100. All the strings are only consist of lowercase letters.

Output:

Each test should output an integer indicating the occurrence of B from A in a single line.

Sample Input:
abab
ab
aaaa
a
aaaa
aa
Sample Output:
3
4
3

之前看错题 用全排 各种超时

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
    char a[1005],b[105],c[105];
    int l,k,i,j,ans;
    while(gets(a))
    {
        gets(b);
        l=strlen(b);
        k=strlen(a);
        ans=0;
        for(i=0;i<=k-l;i++)
        {
            for(j=0;j<l;j++)
            {
                strncpy(c+j,b,l-j);
                strncpy(c,b+l-j,j);
                if(strncmp(a+i,c,l)==0)
                {
                    ans++;
                    break;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值